Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3. Программа получает на вход целые числа. Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000. Программа должна вывести одно число: количество четных чисел, кратных 3.
Answers & Comments
var i, k, count: integer;
A: array[1..N] of integer;
begin
writeln ('vvedite chisla');
for i:=1 to N do begin
k:=k+1;
readln(A[k]);
if A[k]=0 then
break
end;
for i:=1 to K-1 do
if A[k] mod 3 =0 then
count:=count+1;
writeln('кол-во чисел, кратных трем: ', count);
end.