Напишите программу, которая в последовательности целых чисел определяет среднее арифметическое
отрицательных чисел, кратных 6. Программа получает на вход целые числа, среди них есть хотя бы одно
отрицательное число, кратное 6, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30000.
Программа должна вывести одно число: среднее арифметическое отрицательных чисел, кратных 6.
Напишите программу, которая в последовательности натуральных чисел определяет сумму чётных чисел,
кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно,
последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в
последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести одно число: сумму чётных чисел, кратных 3
Answers & Comments
Verified answer
Program n1;var a,sum,k: integer;
begin
readln(a);
sum:=0;
k:=0;
while a<>0 do begin
if (a<0) and (a mod 6=0) then begin
k:=k+1;
sum:=sum+a;
end;
readln(a);
end;
writeln(sum/k);
end.
Program n2;
var a,sum: integer;
begin
readln(a);
sum:=0;
while a<>0 do begin
if (a mod 2=0) and (a mod 3=0) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.