Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 5. С++
Answers & Comments
#include <iostream>
using namespace std;
int main(){
int n, m=-30001, a;
cin>>n;
for (int i=0; i<n; ++i){
cin>>a;
if (a%5==0 and a>m) m=a;
}
cout<<m;
}