Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число.
Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число.
Проgа нужна на языке паскаль.
Answers & Comments
//Версия 3.3, сборка 1634
begin
write(ReadSeqInteger(ReadInteger).Where(x->x.IsEven).Min);
end.
Verified answer
Var count,min,this : integer;begin
min:= maxint-1;
read(count);
for var i:= 1 to count do
begin
Read(this);
if(this mod 2 = 0) and (this<min) then
min:= this;
end;
writeLn(min);
end.