Напишите программу, которая заполняет массив из 16 элементов случайными числами на отрезке [-4;4] находит произведение ненулевых элементов. СРОЧНО! ДАЮ 50 БАЛЛОВ!
begin randomize; p:=1; for i :=1 to 16 do begin a[i] := random(-4,4); if (a[i] <> 0) then p:=p* a[i]; write(a[i]+' '); end; writeln(); write('Произведение = ', p); end.
Answers & Comments
Verified answer
Program fpro;var
a : array[1..16] of integer;
i,p : integer;
begin
randomize;
p:=1;
for i :=1 to 16 do begin
a[i] := random(-4,4);
if (a[i] <> 0) then p:=p* a[i];
write(a[i]+' ');
end;
writeln();
write('Произведение = ', p);
end.