Напишите программу, которая заполняет массив из N элементов степенями числа 2, начиная с 2 1 до 2 N , в обратном порядке.
Входные данные
Входная строка содержит размер массива N . Гарантируется, что 0 < N ≤ 30 .
Выходные данные
Программа должна вывести содержимое массива: N первых степеней числа 2 в обратном порядке (последний элемент должен быть равен 2 1 ).
Примеры
входные данные
5
выходные данные
32 16 8 4 2
Answers & Comments
Verified answer
Program n1;var a: array[1..30] of integer;
n,i: integer;
function st(i: integer): integer;
begin
st:=1;
for i:=1 to i do st:=st*2
end;
begin
readln(n);
for i:=1 to n do a[i]:=st(i);
for i:=n downto 1 do write(a[i],' ');
end.