Напишите программу на С++, которая заменяет в символьной строке все буквы a на буквы b (латинские, строчные). Решение с комментариями к
каждой строке кода. Комментарии должны пояснять, что происходит в каждой строке программы, для чего она нужна и т.п.
Входные данные
Входная строка содержит символы латинского алфавита, как строчные, так и заглавные.
Выходные данные
Программа должна заменить во всей строке строчные буквы a на буквы b и вывести в первой строке получившуюся символьную строку, а во второй – количество выполненных замен.
Примеры
входные данные
aabbccabadef
выходные данные
bbbbccbbbdef
4
Answers & Comments
Ответ:
#include <iostream>
int main()
{
char str[80]; // Объявление символьной строки
int i = 0, cnt = 0; // Объявление переменных i и cnt целого типа - счетчик для цикла
// и переменная, в которой будем считать кол-во замен
std::cin >> str; // Считывание строки из консоли в символьную строку str
while (str[i] != '\0') // Пока очередной символ не станет равен символу конца строки
{
if (str[i] == 'a')
{
str[i] = 'b'; // Заменяем символ 'a' на символ 'b'
cnt++; // Увеличиваем счетчик замен на единицу
}
i++; //переходим к следующему символу
}
std::cout << str << std::endl; // Выводим измененную символьную строку на экран
std::cout << cnt; // Выводим количество замен
return 0;
}