Напишите программу на языке Паскаль, чтобы с её помощью можно было найти наименьший общий делитель произвольных десяти целых двузначных чисел. Срочнооооо
Answers & Comments
gangstart
1 program Ivan; 2 var 3 m,z:real; 4 i,a,b:integer; 5 begin 6 writeln('Ввести a,b'); 7 readln(a,b); 8 if a<b then m:=a else m:=b; 9 for i:=1 to m do if a mod i=0 and b mod i=0 then z=i; 10 writeln(z); 11 end.
Answers & Comments
2 var
3 m,z:real;
4 i,a,b:integer;
5 begin
6 writeln('Ввести a,b');
7 readln(a,b);
8 if a<b then m:=a else m:=b;
9 for i:=1 to m do if a mod i=0 and b mod i=0 then z=i;
10 writeln(z);
11 end.