Напишите программу на языке Паскаль, для решения следующей задачи: Для любого четырехзначного вводимого числа найти сумму второй и предпоследней цифры). (Подсказка. Используйте тип данных integer и операции div и mod)
Answers & Comments
redra1n
Var a,b,c,d:integer; begin readln(a); b:=(a div 100)mod 10; c:=(a mod 100)div 10; d:=b+c; writeln(d); readln; end.
Answers & Comments
begin
readln(a);
b:=(a div 100)mod 10;
c:=(a mod 100)div 10;
d:=b+c;
writeln(d);
readln;
end.
begin
read (c);
a:=c div 100; a:=a mod 10;
b:=c div 10; b:=b mod 100;
write(a+b);
end.