Home
О нас
Products
Services
Регистрация
Войти
Поиск
kirane
@kirane
July 2022
2
5
Report
напишите программу удаляющая из текста все буквы совпадающие с его последней буквой
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
yasadc
Uses crt;
var s:string;
n,i:integer;
begin
readln(s);
n:=length(s);
for i:=1 to n do
if s[i]=s[n] then delete(s,i,1);
writeln(s);
end.
Эта программа рассчитана на то, что удаляется и последний символ тоже
1 votes
Thanks 1
kirane
ага , сейчас проверю
kirane
аа получилось))))
Segrif
А у меня выход за границы массива, т.к. n не меняется, ну да ладно.
kirane
у меня все подошло)))
Segrif
Var s:string; i:integer;
begin
read(s);
i:=1;
while i<length(s) do
if s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i)
else i+=1;
write(s)
end.
1 votes
Thanks 1
kirane
тоже спасибо)))
kirane
оо, у тебя не удаляет, я незнаю какой точно переписывать
kirane
спасибо))))
Segrif
А, у вас обычный или .net? Если обычный, то лучше другой вариант.
kirane
обычный
Segrif
Ясно
More Questions From This User
See All
kirane
August 2022 | 0 Ответы
reshite i obyasnite pozhalujsta kak reshayutsya takie zadachihozyajka sobrala 18 kg ka
Answer
kirane
August 2022 | 0 Ответы
reshite pozhalujstaaaaaaa najdite proizvodnuyu
Answer
kirane
August 2022 | 0 Ответы
koren iz raznosti kornya iz 5 i kornya iz 3
Answer
kirane
July 2022 | 0 Ответы
pliiizlyudi reshitenapishite programmu opredelyayushuyu kakaya iz bukv pervaya ili
Answer
kirane
July 2022 | 0 Ответы
napisat programmu kotoraya zaprashivaet vozrast muzhchiny i soobshaet skolko let em
Answer
kirane
July 2022 | 0 Ответы
sdelat polnyj sintaksicheskij razbor predlozheniya ya pohvalil devochku zaa to chto
Answer
kirane
July 2022 | 0 Ответы
postroit harakternye intervaly v tonalnosti fis dur
Answer
kirane
July 2022 | 0 Ответы
pomogite pozhalujstavychislite summu chetnyh elementov odnomernogo massiva do 1
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
o chem dolzhny pozabotitsya v pervuyu ochered vzroslye pri organizacionnom vyvoze n
danilarsentev
August 2022 | 0 Ответы
est dva stanka na kotoryh vypuskayut odinakovye zapchasti odin proizvodit a zapcha
myachina8
August 2022 | 0 Ответы
najti po grafiku otnoshenie v3v1 v otvetah napisano 9 no nuzhno reshenie
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
opredelite kak sozdavalas i kto sozdaval arabskoe gosudarstvo v kracii
MrZooM222
August 2022 | 0 Ответы
ch ajtmanov v rasskaze krasnoe yabloko ispolzuet metod rasskaz v rasskaze opi
timobila47
August 2022 | 0 Ответы
kakovo bylo naznachenie kazhdoj iz chastej vizantijskogo hrama pomogite pozhalujsta
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
pozhalujsta8b98a56c0152a07b8f4cbcd89aa2f01e 97513
sarvinozwakirjanova
August 2022 | 0 Ответы
pomogite pozhalusto pzha519d7eb8246a08ab0df06cc59e9dedb 6631
×
Report "напишите программу удаляющая из текста все буквы совпадающие с его последней бук..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
var s:string;
n,i:integer;
begin
readln(s);
n:=length(s);
for i:=1 to n do
if s[i]=s[n] then delete(s,i,1);
writeln(s);
end.
Эта программа рассчитана на то, что удаляется и последний символ тоже
begin
read(s);
i:=1;
while i<length(s) do
if s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i)
else i+=1;
write(s)
end.