Ниже записана программа. Получив на вход число x , эта программа печатает два числа, a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 0.
var x, a, b : integer;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
a := a + 1;
b := b * (x mod 10);
x := x div 10;
end;
writeln(a); write(b);
end.
Answers & Comments
Verified answer
В а - количество цифр в числев b - произведение цифр
то есть число x - трехзначное и произведение его цифр=0,
990 - максимальное из трёхзначных, произведение цифр которых=0
ответ 990