номер 6. Составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов( по программе Паскаль ) ПОМОГИТЕ ПОЖАЛУЙСТА !!!!
begin write('Введите значения коэффициентов квадратного уравнения: '); readln(a, b, c); if a = 0 then writeln('Это не квадратное уравнение!') else begin D := b * b - 4 * a * c; if D > 0 then begin writeln('Уравнение имеет два корня:'); writeln('x1 = ', (-b - sqrt(D)) / (2 * a)); writeln('x2 = ', (-b + sqrt(D)) / (2 * a)); end else if D = 0 then begin writeln('Ураннение имеет один корень:'); writeln('x = ', -b / (2 * a)); end else writeln('Уравнение не имеет действительных корней'); end; end.
Answers & Comments
Verified answer
Vara, b, c, d: real;
begin
write('Введите значения коэффициентов квадратного уравнения: ');
readln(a, b, c);
if a = 0 then
writeln('Это не квадратное уравнение!')
else begin
D := b * b - 4 * a * c;
if D > 0 then begin
writeln('Уравнение имеет два корня:');
writeln('x1 = ', (-b - sqrt(D)) / (2 * a));
writeln('x2 = ', (-b + sqrt(D)) / (2 * a));
end else if D = 0 then begin
writeln('Ураннение имеет один корень:');
writeln('x = ', -b / (2 * a));
end else
writeln('Уравнение не имеет действительных корней');
end;
end.