Home
О нас
Products
Services
Регистрация
Войти
Поиск
beenchmark
@beenchmark
August 2022
1
23
Report
нужно написать программу на языке Паскаль, которая будет убирать из строки все символы кроме цифр. Пример: входной- a3f4h5k&2 выходной:3452
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
ZusTY
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
var s:=ReadlnString;
s:=s.Where(d->d in ['0'..'9']).JoinIntoString('');
Writeln(s)
end.
Тестовое решение:
a3f4h5k&2
3452
2 votes
Thanks 1
beenchmark
а без OR можно как нибудь?
ZusTY
без понятия
ZusTY
можно наверное
ZusTY
но я не настолько хорошо стринг знаю
beenchmark
там блин как-то диапозон можно выставить, а я забыл как =)
Segrif
if (s[i] >= '0') and (s[i] <= '9')
По стандарту языка, вроде как, цифры должны идти по порядку
ZusTY
да, ты прав
srzontmp
А где удаление символов из строки, как в задании написано?
beenchmark
там смотри условие, если данный символ число то печатать его крч =)
More Questions From This User
See All
beenchmark
July 2022 | 0 Ответы
trebuetsya najti samuyu dlinnuyu nepreryvnuyu cepochku nulej v posledovatelnosti nul
Answer
beenchmark
July 2022 | 0 Ответы
dana stroka iz n simvolovvse chisla zakanchivayushayasya nulem nol v etoj stroke
Answer
beenchmark
March 2022 | 0 Ответы
kak vvesti strokovyj tip dannyh string cherez probel v paskale
Answer
beenchmark
March 2022 | 0 Ответы
dana strokastring iz treh chisel razdelennyh probelom nuzhno ih prisvoit k a1
Answer
beenchmark
March 2022 | 0 Ответы
dana programma kotoraya dolzhna udalyat probely iz stroki program var15stroki
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
o chem dolzhny pozabotitsya v pervuyu ochered vzroslye pri organizacionnom vyvoze n
danilarsentev
August 2022 | 0 Ответы
est dva stanka na kotoryh vypuskayut odinakovye zapchasti odin proizvodit a zapcha
myachina8
August 2022 | 0 Ответы
najti po grafiku otnoshenie v3v1 v otvetah napisano 9 no nuzhno reshenie
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
opredelite kak sozdavalas i kto sozdaval arabskoe gosudarstvo v kracii
MrZooM222
August 2022 | 0 Ответы
ch ajtmanov v rasskaze krasnoe yabloko ispolzuet metod rasskaz v rasskaze opi
timobila47
August 2022 | 0 Ответы
kakovo bylo naznachenie kazhdoj iz chastej vizantijskogo hrama pomogite pozhalujsta
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
pozhalujsta8b98a56c0152a07b8f4cbcd89aa2f01e 97513
sarvinozwakirjanova
August 2022 | 0 Ответы
pomogite pozhalusto pzha519d7eb8246a08ab0df06cc59e9dedb 6631
×
Report "нужно написать программу на языке Паскаль, которая будет убирать из строки все с..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
begin
var s:=ReadlnString;
s:=s.Where(d->d in ['0'..'9']).JoinIntoString('');
Writeln(s)
end.
Тестовое решение:
a3f4h5k&2
3452
По стандарту языка, вроде как, цифры должны идти по порядку