Объясните суть этой программы, а конкретнее, что в ней делают функции inc и Dec. Задача: Полоска бумаги имеет размеры А*B клеточек (1≤A,B≤10^6). Каждый раз от неё отрезается квадрат максимального размера до тех пор, пока не получится квадрат. Определите, сколько квадратов получится.
Программа на Паскале:
program m_1;
var A:longint;
B:longint;
N:integer;
begin
readln (A,B);
N:=1;
while A<>B do
begin inc(N);
if A>B then Dec(A,B) else
Dec (B,A);
end;
writeln (N)
end.
Answers & Comments
Функция inc(x, a) увеличивает х на а единиц.
Функция dec(x, b) уменьшает x на b единиц.
Если количество единиц не указано, то +1, либо -1.
Пока стороны A и B не равны,т.е пока не получится квадрат:
1). Увеличиваем счетчик квадратов N на единицу.
2) . Уменьшаем сторону побольше, отняв длину стороны поменьше. ( "Отрезаем квадрат")