PASCAL
1. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел,
кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами
числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает
100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму чисел,
кратных 5.
2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное
число, оканчивающееся на 4. Программа получает на вход количество чисел в
последовательности, а затем сами числа. В последовательности всегда имеется число,
оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30
000. Программа должна вывести одно число — минимальное число, оканчивающееся на 4.
Answers & Comments
Ответ:
Всё напишу в объяснении.
Объяснение:
1) Program Ex1;
var
n, a, i, sum : integer;
begin
sum := 0; // обнуляем счетчик суммирования
read(n); // вводим кол-во чисел
for i := 0 to n do
begin
read(a); // считываем эти числа
if (a mod 5 = 0) then sum := sum + a; // если число кратно 5, то добавляем его к сумме
end;
writeln(sum); // выводим сумму.
end.
2) Program Ex2;
var
n, a, i, min: integer;
begin
min := 30000;
read(n); // вводим кол-во чисел
for i := 0 to n do
begin
read(a); // считываем эти числа
if ((a mod 10 = 4) and (a < min)) then min := a; // ищем минимум
end;
writeln(min); // выводим минимум
end.