Pascal!!!!!
Исправьте ошибки в задаче


Program Partiii;
Var n, NumParties, i, j, t: integer;
Count:array[1..10] of integer;
s: string[50];
Names: array[1..10] of string;
Begin
NumParties:=0;
ReadLn(N);
for i:=1 to NumParties do
begin
max:=count[i];
n:=i;
for l:=1 to NumParties do
begin
if count[l]>max then
begin
max:=count[l];
n:=l;
end;
end;
if names[n]<>'' then begin
writeln (names[n]);
count[n]:=-1;
names[n]:='';
end;
end;
for i:=2 to NumParties do
if Count[i-1]>n then
begin
n:=Count[i];
t:=i;
end;
WriteLn(Names[t])
end.

Вот какое было задание,
Доработайте программу так, чтобы она решала следующую задачу:
1) Программа должна вывести список всех партий, встречающихся в исходном списке, в порядке убывания количества голосов, отданных за эту партию. При этом название каждой партии должно быть выведено ровно один раз, вне зависимости от того, сколько голосов было отдано за данную партию. Пример выходных данных для приведенного выше примера входных данных:
Party three
Party two
Party one

2) На вход программы подается список, при этом некоторые голоса являются недействительными, в этом случае вместо названия партии записан один символ «.» (точка). Партия проходит в парламент, если за нее отдано не менее 7% от общего числа действительных голосов (то есть от количества строк в списке, которые не равны «.»). Программа должна вывести список всех партий, прошедших в парламент, в произвольном порядке. При этом название каждой партии должно быть выведено ровно один раз, вне зависимости от того, сколько голосов было отдано за данную партию.
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Answers & Comments


Copyright © 2025 SCHOLAR.TIPS - All rights reserved.