Pascal. Написать программу: нахождения цифры в числе с максимальным значением. 9й класс.
Answers & Comments
KaPTowe4Kauses crt; var a,Max,x:integer; begin clrscr; Write('Введите число: '); readln(a); Max:=a mod 10; while a>0 do begin x:=a mod 10; a:=a div 10; if x>Max then Max:=x; end; Writeln('Максимальная цифра: ',Max); readln; end.
Answers & Comments
var a,Max,x:integer;
begin
clrscr;
Write('Введите число: ');
readln(a);
Max:=a mod 10;
while a>0 do
begin
x:=a mod 10;
a:=a div 10;
if x>Max then Max:=x;
end;
Writeln('Максимальная цифра: ',Max);
readln;
end.