PASCAL
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 5.Количество чисел не превышает 100. Введённые числа по модулю
не превышают 300.Программа должна вывести одно число: сумму чисел, оканчивающихся на 5.
Answers & Comments
var sum,k,i:integer;
begin
readln(k);
writeln;
sum:=0;
repeat
read(i);
if (i>0) and (i mod 10=5) then sum:=sum+i;
k:=k-1;
until k=0;
writeln(sum);
end.
----
Так как последовательность натуральных чисел, я ввела условие i>0 для суммы. Если подразумевается, что вводятся только положительные числа, это условие можно убрать.