ПАСКАЛЬ, ЦИКЛ WHILE (чем проще, тем лучше)
Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 5. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 5.
Answers & Comments
Объяснение:
var a,k:integer;
begin
k:=0;
readln(a);
while a<>0 do begin
if (a mod 5 = 0) and (a mod 2=0) then
k:=k+1;
readln(a)
end;
writeln(k);
end.