Паскаль, помогите пожалуйста Составьте программу вычисления в массиве B(N) минимального среди положительных элементов и его номера
Answers & Comments
ЮлияКолесник
Const N=10; var a: array [0..N] of integer; i, m: integer; begin for i := 0 to N do a[i] := random(1000) - 500; { Надо же что-то в массив закинуть =) } for i := 0 to N do if ((a[i] > 0) and (a[i] > a[m])) then m := i; writeln('[', m, '] => ', a[m]); end.
Answers & Comments
var a: array [0..N] of integer;
i, m: integer;
begin
for i := 0 to N do
a[i] := random(1000) - 500; { Надо же что-то в массив закинуть =) }
for i := 0 to N do
if ((a[i] > 0) and (a[i] > a[m])) then
m := i;
writeln('[', m, '] => ', a[m]);
end.