Помогите 3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d параллелограммом. Очень нужно прошу помогите
Answers & Comments
semennovikov123
Pascal : Код чтобы скопировать : http://rextester.com/EFBKO81416
2 votes Thanks 0
Nata9911
Язык C++. #include < iostream > using namespace std; int main(){ int a, b, c, d, u; cout << "Все четыре угла прямые (Да - 1/Нет - 0)?" << endl; cin >> u; switch(u){ case 0:{ cout << "Введите длины сторон: " << endl; cin >> a >> b >> c >> d; if((a==c && d == b) && (a==b && c==d)&&(a==d && b==c) &&(c==b && a == d)) cout << "Не параллелограмм"; else if((a==c && d == b) || (a==b && c==d)||(a==d && b==c) || (c==b && a == d)) cout << "Параллелограмм"; else cout << "Не параллелограмм"; break; } case 1:{ cout << "Не параллелограмм"; } } }
Answers & Comments
Код чтобы скопировать : http://rextester.com/EFBKO81416
#include < iostream >
using namespace std;
int main(){
int a, b, c, d, u;
cout << "Все четыре угла прямые (Да - 1/Нет - 0)?" << endl;
cin >> u;
switch(u){
case 0:{
cout << "Введите длины сторон: " << endl;
cin >> a >> b >> c >> d;
if((a==c && d == b) && (a==b && c==d)&&(a==d && b==c) &&(c==b && a == d))
cout << "Не параллелограмм";
else if((a==c && d == b) || (a==b && c==d)||(a==d && b==c) || (c==b && a == d))
cout << "Параллелограмм";
else
cout << "Не параллелограмм";
break;
}
case 1:{
cout << "Не параллелограмм";
}
}
}