Помогите дам все свои баллы!!!!!!!! Напишите программу, которая определяет прямоугольный ли треугольник. на ввод программе подаются длины сторон треугольника.
Answers & Comments
danulpopov
Var a, b, c: real; begin Read(a, b, c); if (a * a = b*b + c*c) or (b*b = a*a + c*c) or (c*c = b*b + a*a) then Writeln('Треугольник прямоугольный!') else Writeln('Треугольник непрямоугольный!') end.
Пример:
3 4 5 Треугольник прямоугольный!
0 votes Thanks 0
tkalenko03
а read что такое(прост забыл надо вспомнить и да спасибо)
Answers & Comments
a, b, c: real;
begin
Read(a, b, c);
if (a * a = b*b + c*c) or (b*b = a*a + c*c) or (c*c = b*b + a*a) then
Writeln('Треугольник прямоугольный!')
else
Writeln('Треугольник непрямоугольный!')
end.
Пример:
3 4 5
Треугольник прямоугольный!