Помогите написать программу на Паскале Дана строка текста,знаков препинания в строке нет.напечатать все слова,заканчивающиеся на "ов" С помощью функции Pos
Var s:string; i:integer; begin readln(s); var wo:=s.ToWords(s); for i:=0 to length(wo)-1 do begin; delete(wo[i],pos(' ',wo[i]),1); if (pos('ов',wo[i])=length(wo[i])-1) then writeln(wo[i]); end; end.
Пример ввода: Иов Петров Петрон Человек Пример вывода: Иов Петров
Answers & Comments
Verified answer
//Pascal ABC.NET v3.1 сборка 1172Var
s:string;
i:integer;
begin
readln(s);
var wo:=s.ToWords(s);
for i:=0 to length(wo)-1 do
begin;
delete(wo[i],pos(' ',wo[i]),1);
if (pos('ов',wo[i])=length(wo[i])-1) then writeln(wo[i]);
end;
end.
Пример ввода:
Иов Петров Петрон Человек
Пример вывода:
Иов
Петров