Помогите написать программу на Паскале: Найдите количество четных цифр в десятичной записи числа
Answers & Comments
danbka26
Program znanija; uses crt; var x,k:integer; begin clrscr; writeln( 'Введите число: ' ); Readln(x); while x>1 do begin if x mod 2=0 then k:=k+1; x:= x div 10; end; writeln( 'Количество чётных чисел в числе= ',k ); Readln; End.
Answers & Comments
uses crt;
var x,k:integer;
begin
clrscr;
writeln( 'Введите число: ' );
Readln(x);
while x>1 do begin
if x mod 2=0 then k:=k+1;
x:= x div 10;
end;
writeln( 'Количество чётных чисел в числе= ',k );
Readln;
End.