Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Verified answer
PROGRAM Privet;
VAR
x:real;
BEGIN
writeln('Который час?'); read(x);
if x > 24 then
writeln('Введенное число не является временем ' )
else
begin
if (x>=8) and (x<12) then writeln('Доброе утро!');
if (x>=12) and (x<17) then writeln('Добрый день!');
if(x>=17) and (x<23) then writeln('Добрый вечер!');
if(x>=23) or (x<8) then writeln('Доброй ночи!');
end;
end.
//вторая программа
var
x,x1,x2,y,y1,y2:real;
begin
write('x = '); readln(x);
write('y = '); readln(y);
write('x1 = '); readln(x1);
write('y1 = '); readln(y1);
write('x2 = '); readln(x2);
write('y2 = '); readln(y2);
if ((x - x1) * (x - x2) < 0) and ((y - y1) * (y - y2) < 0) then
writeln('Точка принадлежит заданной области')
else
writeln('Точка не принадлежит заданной области');
end.