Помогите пожалуйста !!!!!! Дам 20 баллов!!!!! Написать программу в Паскале!!!!!!!!!! Написать программу обработки массива размерности n, которая подсчитывает кол-во элементов, которые одновременно делятся на 5 и 2. n=6
Answers & Comments
Burxon21
Если число k одновременно делится на числа p и q, оно также делится на их произведение p×q. Это позволяет упростить проверку и сделать программу оптимальнее.
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018 // Внимание! Если программа не работает, обновите версию!
begin var a:=ReadArrInteger('Элементы массива:',ReadInteger('n=')); Writeln('Найдено элементов ',a.Where(t->t mod 10=0).Count) end.
Пример n= 6 Элементы массива: -38 40 -60 35 0 18 Найдено элементов 3
Answers & Comments
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Элементы массива:',ReadInteger('n='));
Writeln('Найдено элементов ',a.Where(t->t mod 10=0).Count)
end.
Пример
n= 6
Элементы массива: -38 40 -60 35 0 18
Найдено элементов 3