Помогите! Пожалуйста! Даю 100 баллов. Напишите программу на паскале.
шестое Математики и ягоды
Шли как-то два математика по лесу и собирали ягоды. Час шли, два шли, а потом вдруг остановились и решили ягодами помериться. Достали они весы (какой же математик пойдет в лес без весов?) и взвесили свои корзины с собранным урожаем, а потом записали полученные числа a1 и b1 на листочек. После этого второй математик пересыпал все ягоды в корзину к первому (полностью опустошив свою корзину), и они снова взвесили свои корзины, получив числа a2 и b2 соответственно. Наконец, первый математик пересыпал все ягоды в корзину ко второму (полностью опустошив свою корзину); после взвешивания они получили числа a3 и b3 соответственно. Этих данных оказалось достаточно для определения победителя, и довольные математики пошли дальше. Вам же предстоит вычислить массу ягод в корзине каждого из математиков до совершения всех пересыпаний.
Формат входных данных
Входные данные состоят из трёх строк. В i-й строке (1 ≤ i ≤ 3) записаны целые числа ai и bi (0 ≤ ai, bi ≤ 10 000).
Формат результата
В единственной строке выведите пару целых чисел через пробел — сколько ягод собрали, соответственно, первый и второй математик.
Примеры
Входные данные
1 2
2 1
0 3
Результат работы
1 1
Answers & Comments
Ответ:
#include <pch.h>
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "RUSSIAN");//Добавление русского языка
system("color F0");//Замена цвета экрана на белый и текста на черный
int A, B, A1, B1, A2, B2, A3, B3; //Добавление переменных
cout << "Введите результаты первого взвешивания" << endl; //Приглашение к вводу
cin >> A1 >> B1; //Ввод
cout << "Первое взвешивание: " << A1 << " - " << B1 << endl; //Эхо-контроль
if ((A1 < 0) || (B1 < 0))
{
cout << "Ошибка. Введите натуральное число" << endl;
return 1; //Выход по ошибке 1
}
cout << "Введите результаты второго взвешивания" << endl; //Приглашение к вводу
cin >> A2 >> B2; //Ввод
cout << "Второе взвешивание: " << A2 << " - " << B2 << endl; //Эхо-контроль
if ((A2 < 0) || (B2 < 0))
{
cout << "Ошибка. Введите натуральное число" << endl;
return 2; //Выход по ошибке 2
}
cout << "Введите результаты третьего взвешивания" << endl; //Приглашение к вводу
cin >> A3 >> B3; //Ввод
cout << "Третье взвешивание: " << A3 << " - " << B3 << endl; //Эхо-контроль
if ((A3 < 0) || (B3 < 0))
{
cout << "Ошибка. Введите натуральное число" << endl;
return 3; //Выход по ошибке 3
}
//Вычисления
A = A1 - A3;
B = B1 - B2;
cout << "Первый математик собрал: " << A << endl <<
"Второй математик собрал: " << B << endl; //Вывод результатов
return 0; //Штатный выход
} //end main
Объяснение:
выходит что-то в этом духе в Visual Studio Express 2017
Не совсем понял вот этот момент в задаче: "В i-й строке (1 ≤ i ≤ 3) записаны целые числа ai и bi (0 ≤ ai, bi ≤ 10 000)."
если надо сделать через цикл или что-то изменить - пиши