Помогите пожалуйста) На языке Pascal составить программу, которая находит номер первого встречающегося в массиве числа 7.
Answers & Comments
Şâßĥă11
Var f:text; a:array[1..7] of real; i,k,c,x:integer; s:string; begin for i:=1 to 7 do begin readln(x); a[i]:=x; end; assign(f,'file.txt'); rewrite(f); for i:=1 to 7 do begin str(a[i],s); writeln(f,s); end; close(f); reset(f); k:=0; while not eof(f) do begin readln(f,s); val(s,x,c); if x<0 then k:=k+1; end; close(f); if k<>0 then writeln('В массиве ',k,' отрицательных элемента(ов)'); else writeln('В массиве нет отрицательных элементов'); erase(f); end.
Answers & Comments
begin
for i:=1 to 7 do
begin
readln(x);
a[i]:=x;
end;
assign(f,'file.txt');
rewrite(f);
for i:=1 to 7 do
begin
str(a[i],s);
writeln(f,s);
end;
close(f);
reset(f);
k:=0;
while not eof(f) do
begin
readln(f,s);
val(s,x,c);
if x<0 then k:=k+1;
end;
close(f);
if k<>0 then writeln('В массиве ',k,' отрицательных элемента(ов)');
else writeln('В массиве нет отрицательных элементов');
erase(f);
end.