Помогите, пожалуйста, написать программу алгоритма поисков и сортировки для массива
Answers & Comments
FunSociety
const n=10; var a:array[1..n] of real; i:integer; k:real; begin write('введите ',n,' элементов массива:'); for i:=1 to n do read(a[i]); i:=1; while i<n do if a[i + 1]<a[i] then begin k:=a[i]; a[i]:=a[i+1]; a[i+1]:=k; i:=1; end else i:= i+1; write('отсортированный массив:'); for i:=1 to n do write(a[i]:8:2); end.
Answers & Comments
var
a:array[1..n] of real;
i:integer;
k:real;
begin
write('введите ',n,' элементов массива:');
for i:=1 to n do read(a[i]);
i:=1;
while i<n do
if a[i + 1]<a[i] then begin
k:=a[i];
a[i]:=a[i+1];
a[i+1]:=k;
i:=1;
end
else i:= i+1;
write('отсортированный массив:');
for i:=1 to n do write(a[i]:8:2);
end.