Помогите пожалуйста написать программу на ABC Pascal. Определить долю гласных букв в заданном тексте на английском языке.
Answers & Comments
PopCop312
Const b:array[1..12] of string=('A','a','E','e','I','i','O','o','U','u','Y','y'); var a:string; i,j,k:integer; begin readln(a); for i:=1 to length(a) do for j:=1 to 12 do if a[i]=b[j] then k+=1; writeln(k/length(a):3:2); end.
Answers & Comments
var a:string;
i,j,k:integer;
begin
readln(a);
for i:=1 to length(a) do
for j:=1 to 12 do
if a[i]=b[j] then k+=1;
writeln(k/length(a):3:2);
end.