Помогите , пожалуйста, написать программу на паскале ! :))) 1 1 3 1 3 5 1 3 5 7 1 3 5 7 9 нужно вывести числа в таком порядке ( в паскале)
Answers & Comments
ZaXoD
Var a,b,i,i2:integer; Begin Readln(a); b:=1; for i:=1 to a do begin if b mod 2 = 0 then b:=b+1; for i2:=1 to b do if i2 mod 2 <>0 then Write(i2,' '); b:=b+1; Writeln(); end; End.
0 votes Thanks 1
ZaXoD
крч a здесь - количество строчек которое ты хочешь получить
Answers & Comments
a,b,i,i2:integer;
Begin
Readln(a);
b:=1;
for i:=1 to a do begin
if b mod 2 = 0 then b:=b+1;
for i2:=1 to b do if i2 mod 2 <>0 then Write(i2,' ');
b:=b+1;
Writeln();
end;
End.