Помогите, пожалуйста, написать программу на паскале по заданию: сформировать двумерный массив B размером 4 x 4 (4 – количество строк; 4 – количество столбцов) с помощью генератора случайных чисел и вывести элементы массива на экран и в файл. Вычислить и вывести на экран и в файл строку матрицы B, содержащую максимальное количество отрицательных элементов (оформить вычисление количества отрицательных элементов в виде функции). Сделал пока что первую часть, не знаю как дальше:
var ar:array[1..4, 1..4] of integer;
i, j:byte;
f:text;
begin
assign(f,'mas.txt');
rewrite(f);
randomize;
for i:=1 to 4 do
begin
for j:=1 to 4 do
begin
ar[i, j]:= random (200) - 100;
write (IntToStr(ar[i, j])+' ');
write (f, IntToStr(ar[i, j])+' ');
end;
writeln (f, ''); writeln ();
end;
close (f);
end.
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Copyright © 2024 SCHOLAR.TIPS - All rights reserved.