Помогите, пожалуйста, написать программу на языке паскаль " Напишите программу поиска максимального из четырех чисел с использованием подпрограммы поиска большего из двух. "
Program n1; var a,b,c,d: integer; function max(a,b: integer): integer; begin if a>b then max:=a else max:=b; end; begin readln(a,b,c,d); if max(a,b)> max(c,d) then write(max(a,b)) else write(max(c,d)); end.
2 votes Thanks 1
NV86DEMON
При выводе результата в основной программе надо что бы было 2 значений, а не 4 (a,b,c,d)
AnonimusPro
программа выведет не 4, а одно максимальное число
NV86DEMON
Это я знаю, но препод требует, что бы в программе было написано 2 значения, а не 4 при выводе, ибо "поиска большего из двух."
Answers & Comments
Verified answer
Program n1;var a,b,c,d: integer;
function max(a,b: integer): integer;
begin
if a>b then max:=a else max:=b;
end;
begin
readln(a,b,c,d);
if max(a,b)> max(c,d) then write(max(a,b)) else write(max(c,d));
end.