Помогите пожалуйста написать программу в Pascal ABC с оператором FOR.А то сам незнаю!Срочно дам 488 баллов!
Answers & Comments
Рибocома
Program for1; var i, n: integer; begin write ('Количество знаков: '); readln (n); writeln('Выводим ', n, 'знаков (*) ') for i := 1 to n do write ('(*) '); readln end.
program for2; //программа, которая будет выводить на экран квадраты чисел от 1 до 10. uses crt; var N:integer; begin clrscr; For N:=1 To 10 Do writeln (sqr(N)); readln end.
Рибocома
если у Вас версия Паскаля ABC, то пустое readln можно не писать
Девушка10клПример 1. Квадраты чисел от 2-х до 10-и. for x:=2 to 10 do WriteLn(x*x); Пример 2. Латинский алфавит. for ch:='A' to 'Z' do Writeln(ch); Пример 3. Использование цикла с downto. for i:=10 downto 1 do WriteLn(i); Пример 4. Использование составного оператора. for x:=1 to 10 do begin y:=2*x+3; WriteLn('f(',x,')=',y); end;
Answers & Comments
var
i, n: integer;
begin
write ('Количество знаков: ');
readln (n);
writeln('Выводим ', n, 'знаков (*) ')
for i := 1 to n do
write ('(*) ');
readln
end.
program for2; //программа, которая будет выводить на экран квадраты чисел от 1 до 10.
uses crt;
var N:integer;
begin
clrscr;
For N:=1 To 10 Do
writeln (sqr(N));
readln
end.
можно не писать