Home
О нас
Products
Services
Регистрация
Войти
Поиск
Rasta13
@Rasta13
July 2022
2
9
Report
Помогите, пожалуйста, написать программу в паскале!!
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
makentikz
Var
i, k: integer;
s: real;
begin
s := 1;
for i := 1 to 10 do
begin
k := k + i;
s := s * k;
writeln(i:3,k:3,' ',s);
end;
writeln(s);
end.
0 votes
Thanks 0
Rasta13
почему получается отрицательное число??
archery
переполнение стека
Rasta13
эм?
archery
данные больше чем максимальное значение возможное для этого типа и оно переходит в минуса
Rasta13
ясно, спасибо
makentikz
можно попробовать Int64, только нужно использовать free pascal.
archery
real хватает
archery
Verified answer
Program zadacha;
var
i:integer;
s,p:longint;
begin
s:=1;
p:=1;
for i:=2 to 10 do begin
p:=p+i;
s:=s*p;
end;
write(s);
end.
2 votes
Thanks 1
Rasta13
все равно не получается
Rasta13
просто складывала и умножала, как и нужно в задании
archery
какой ответ?
Rasta13
должно получиться 144598608000
makentikz
если по задаче вычислять, то должно выйти 141455160000
archery
у меня 141455160000
makentikz
как и у меня
archery
скорее всего у Расты ошибка в рассчетах, ведь цифры весьма похожи
Rasta13
ой
неправильно чо-то посчитала как всегда
Rasta13
да-да, у вас правильно
спасибо большое!
можете еще посмотреть задачки?
http://znanija.com/task/3974660
More Questions From This User
See All
Rasta13
August 2022 | 0 Ответы
kolebatelnyj kontur sostoit iz katushki induktivnosti i kondensatora v nyom nabl93c58c58e407114ddcb025ec9d5ad25d 86736
Answer
Rasta13
August 2022 | 0 Ответы
s on naletaet na nepodvizhnuyu telezhku massoj 01 kg prikreplennuyu k pruzhine i
Answer
Rasta13
August 2022 | 0 Ответы
na risunke shematicheski izobrazhena lestnica as prislonennaya k stene chemu raven27cbeba9a7046a59391652eaf01e43eb 96135
Answer
Rasta13
August 2022 | 0 Ответы
kosmicheskaya raketa udalyaetsya ot zemli na kakom rasstoyanii ot zemnoj poverhnostib6af9e7ca290753a02f2eda61a18298f 37389
Answer
Rasta13
August 2022 | 0 Ответы
obyasnite pozhalujsta krasnaya granica fotoeffekta issleduemogo metalla sootve
Answer
Rasta13
August 2022 | 0 Ответы
s a tormozhenie bylo ravnozamedlennym 1 1 2 5 3 3 4 4 obyasnite pozhaluj
Answer
Rasta13
August 2022 | 0 Ответы
idealnyj gaz pereshel iz sostoyaniya 1 v sostoyanie 2 v processe predstavlennom na
Answer
Rasta13
August 2022 | 0 Ответы
3)...
Answer
Rasta13
August 2022 | 0 Ответы
t gde period t 1 s cherez kakoe minimalnoe vremya nachinaya s momenta t 0
Answer
Rasta13
August 2022 | 0 Ответы
5 n obyasnite pozhalujsta
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
o chem dolzhny pozabotitsya v pervuyu ochered vzroslye pri organizacionnom vyvoze n
danilarsentev
August 2022 | 0 Ответы
est dva stanka na kotoryh vypuskayut odinakovye zapchasti odin proizvodit a zapcha
myachina8
August 2022 | 0 Ответы
najti po grafiku otnoshenie v3v1 v otvetah napisano 9 no nuzhno reshenie
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
opredelite kak sozdavalas i kto sozdaval arabskoe gosudarstvo v kracii
MrZooM222
August 2022 | 0 Ответы
ch ajtmanov v rasskaze krasnoe yabloko ispolzuet metod rasskaz v rasskaze opi
timobila47
August 2022 | 0 Ответы
kakovo bylo naznachenie kazhdoj iz chastej vizantijskogo hrama pomogite pozhalujsta
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
pozhalujsta8b98a56c0152a07b8f4cbcd89aa2f01e 97513
sarvinozwakirjanova
August 2022 | 0 Ответы
pomogite pozhalusto pzha519d7eb8246a08ab0df06cc59e9dedb 6631
×
Report "Помогите, пожалуйста, написать программу в паскале!!..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
i, k: integer;
s: real;
begin
s := 1;
for i := 1 to 10 do
begin
k := k + i;
s := s * k;
writeln(i:3,k:3,' ',s);
end;
writeln(s);
end.
Verified answer
Program zadacha;var
i:integer;
s,p:longint;
begin
s:=1;
p:=1;
for i:=2 to 10 do begin
p:=p+i;
s:=s*p;
end;
write(s);
end.
неправильно чо-то посчитала как всегда
спасибо большое!
можете еще посмотреть задачки?
http://znanija.com/task/3974660