Помогите пожалуйста, не шарю вообще! Составить программу, содержащую ветвление и определяющую, принадлежит ли точка с координатами (Х,У) заштрихованной области
Answers & Comments
srzontmp
Var x,y: real; begin write('x y через пробел: '); readln(x,y); if ((-6<=x) and (x<=1) and (-3<=y) and (y<=7)) and not ((-3<x) and (x<=1) and (-3<=y) and (y<2)) then writeln('точка принадлежит области') else writeln('точка не принадлежит области'); end.
x y через пробел: -2 1.5 точка не принадлежит области
Answers & Comments
begin
write('x y через пробел: '); readln(x,y);
if ((-6<=x) and (x<=1) and (-3<=y) and (y<=7)) and
not ((-3<x) and (x<=1) and (-3<=y) and (y<2)) then
writeln('точка принадлежит области')
else writeln('точка не принадлежит области');
end.
x y через пробел: -2 1.5
точка не принадлежит области
x y через пробел: - 4 5
точка принадлежит области