помогите, пожалуйста) нужно написать программу (условие)для закрашенной области в паскале 1-14 варианты
Answers & Comments
coolrussianmprogram mnoga; var x, y: integer; begin read(x, y); if ((y<0) and (sqr(x - 3) + sqr(y)<1) or ((y>0) and (y<2) and (sqr(x - 3) + sqr(y)>1))) then writeln('YES') else writeln('NO') end.
Answers & Comments
var
x, y: integer;
begin
read(x, y);
if ((y<0) and (sqr(x - 3) + sqr(y)<1) or ((y>0) and (y<2) and (sqr(x - 3) + sqr(y)>1))) then
writeln('YES')
else
writeln('NO')
end.