Помогите пожалуйста с информатикой.
Составить программу на языке си:
Дан вещественный массив, состоящий из 67 элементов. Найти произведение положительных элементов, у которых порядковый номер элемента кратен 6. (Нумерация элементов массива начинается с нуля).
Answers & Comments
Ответ:
Вариант C:
#include <stdio.h>
#define SIZE 10
int main(void)
{
float result = 1;
float array[SIZE];
for(int i = 0; i < SIZE; ++i)
{
scanf("%f", &array[i]);
if(array[i] > 0 && (i % 6 == 0))
{
result *= array[i];
}
}
printf("Произведение элементов, удовл. условию = %f", result);
return 0;
}
Вариант C++:
#include <iostream>
const int _size = 67;
int main()
{
float result = 1;
float arr[_size];
for(int i = 0; i < _size; ++i)
{
std::cin >> arr[i];
if(arr[i] > 0 && (i % 6 == 0))
{
result *= arr[i];
}
}
std::cout << "Результат = " << result;
return 0;
}
Объяснение:
Проверяем элемент. Если он больше нуля и стоит на позиции, кратной 6, то добавляем в общее произведение.