Помогите, пожалуйста с задачей Python площадь треугольника ACMP №822
Площадь треугольника
По целочисленным координатам вершин треугольника (x1,y1), (x2,y2) и (x3,y3) требуется вычислить его площадь.
Входные данные
Входной файл INPUT.TXT содержит 6 целых чисел x1,y1,x2,y2,x3,y3 – координаты вершин треугольника. Все числа не превышают 106 по абсолютной величине.
Выходные данные
В выходной файл OUTPUT.TXT выведите точное значение площади заданного треугольника.
Answers & Comments
Ответ:
var x1,x2,x3,y1,y2,y3,a,b,c,S,P: real;
begin
readln(x1,y1,x2,y2,x3,y3);
a:=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
b:=sqrt((x2-x3)*(x2-x3)+(y2-y3)*(y2-y3));
c:=sqrt((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3));
P:=a+b+c;
writeln('периметр: ',P);
P:=P/2;
S:=sqrt(P*(P-a)*(P-b)*(P-c));
write('площадь: ',S);
end.