Помогите пожалуйста составить программу правильно!!!!!
Вот условие:
Даны два действительных числа X и Y, не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. Программа должна иметь дружественный интерфейс.
На Паскале
Answers & Comments
Begin
write('x = ');readln(x);
write('y = '); readln(y);
if x>y then
Begin
t:=y;
y:=(x+y)/2;
x:=x*t*2;
End
else
Begin
t:=x;
x:=(x+y)/2;
y:=x*t*2;
End;
writeln('X = ',x:0:2);
writeln('Y = ',y:0:2);
readln;
End.