Помогите, пожалуйста, составить программу, в паскале, нахождения суммы цифр четырехзначного числа
var
a: 1000..9999; //Четырехзначное число
a1, a2, a3, a4: 1..9;
begin
writeln('Введите четырехзначное число');
readln(a);
a1:= a mod 10; //Первая с конца цифра
a2:= (a mod 100) div 10; //Вторая с конца цифра
a3:= (a mod 1000) div 100; //Третья с конца цифра
a4:= a div 1000; //Четвертая с конца цифра
writeln('Сумма цифр данного числа: ', a1 + a2 + a3 + a4); //Сумма цифр
end.
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
var
a: 1000..9999; //Четырехзначное число
a1, a2, a3, a4: 1..9;
begin
writeln('Введите четырехзначное число');
readln(a);
a1:= a mod 10; //Первая с конца цифра
a2:= (a mod 100) div 10; //Вторая с конца цифра
a3:= (a mod 1000) div 100; //Третья с конца цифра
a4:= a div 1000; //Четвертая с конца цифра
writeln('Сумма цифр данного числа: ', a1 + a2 + a3 + a4); //Сумма цифр
end.