Помогите пожалуйста! Составьте программу для вычисления значения выражения x в степени n + y в степени m. Значения x,y,n,m >0 вводятся с клавиатуры. Примечание: чтобы возвести число в n-ную степень, надо его умножить само на себя n раз.
Answers & Comments
Laebro
Begin var x, y, n, m: integer; Readln(x, y, n, m); Assert((x > 0) and (y > 0) and (n > 0) and (m > 0)); var upstep: integer := n + y; for var i := 2 to m do upstep *= (n + y); var lowstep := x; for var j := 2 to upstep do lowstep *= x; Writeln(lowstep); end.
0 votes Thanks 0
zontik24
upstep *= (n + y) ? Да ну? Вы Си с Pascal смешали ?
Answers & Comments
var x, y, n, m: integer;
Readln(x, y, n, m);
Assert((x > 0) and (y > 0) and (n > 0) and (m > 0));
var upstep: integer := n + y;
for var i := 2 to m do
upstep *= (n + y);
var lowstep := x;
for var j := 2 to upstep do
lowstep *= x;
Writeln(lowstep);
end.