Помогите пожалуйста. Срочно!!!!!!
1. Написать программу нахождения суммы цифр вводимого с клавиатуры натурального трехзначного числа.
2. Написать программу, определяющую истинность высказывания «Треугольник с длинами сторон a,b,c является равнобедренным» для произвольных целых чисел a,b,c
Answers & Comments
Ответ:
1. Program z1;
var s:string;
a,o,code:integer;
begin
val(s[1],a,code)
o+=a
val(s[2],a,code)
o+=a
val(s[3],a,code)
o+=a
writeln(o)
end.
2. Program z1;
var a,b,c:integer;
begin
if a = b or b = c or a = c
then print('YES')
else print('NO')
end.
Объяснение: