помогите пожалуйста!!!задание по информатике(паскаль)
Составить программу описания двух переменных чисел:трех действительн., трех целых, трех постоянных ,целые(2 чиловые ,1 символьная)
на уроке успели только 1 пример сделать:
Program _ Zadacha _1 ;
const_ s1=3
pi=3.14;
var_c2,c1:integer;
b2:real;
begin
end.
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Начнем сначала. Паскаль является строго типизированным языком, значит чтобы использовать переменную, надо её сначала добавить в специальный блок var.
Константы добавляются отдельно.
Рассмотрим сперва неольшой пример, не имеющий отношение к твоей задаче:
program task1;
var i:integer;
begin
write("Vvedite i: ");
readln(i);
writeln(i);
end.
Программа просто попросит ввести i, запомнит введенное значение в ячейку с именем i.
Так вот чтобы разрешить использовать ячейку с именем i, мы и должны добавить её var i:integer; (ячейка i в которую можно класть целые числа, integer - целое по английски)
Теперь по твоему заданию:
1. в Паскале нет "переменных" чисел,
вот типы, которые есть в Паскале:
для целых чисел:
integer, диапазон -32768..32767
byte, диапазон 0..255
word, диапазон 0..65535
shortint, диапазон -128..127
longint, диапазон -2147483648..2147483647
для вещественных типов (в такие ячейки можно класть как целые числа, так и числа с точкой)
single (мало значащих цифр)
real (средне значащих цифр)
double (много значащих цифр)
extended (очень много значащих цифр)
логический тип
boolean может быть либо true либо false
Символьный тип
char просто любой символ, из поддерживаемых Паскалем (ASCII кодировка)
Таким образом фраза
"Составить программу описания двух переменных чисел" понята мной как:
"Составить программу описания переменных:"
Итак, теперь программа:
program zadacha1;
var
d1,d2,d3:real; {dejstvitelnie, 3 stuki}
i1,i2,i3:integer;{celie, 3 shtuki}
const e=2.71; {Pervaya postojannaya}
g=9.8; {Vtoraya postoyannaya}
gravity=6.61; {Tretjya postoyannaya}
var c1,c2:integer; {dve celie, chislovie}
key:char; {odna simvolnaya}
begin
{zdes' teper' mozhno pisat' programmu}
end.
P.S. во вложении этот же исходный код, а на изображении еще и пример как класть значения в эти переменные.
Задавайте дополнительные вопросы