Помогите пожежуто
1. Создать программу, которая, запросив сторону квадрата, выдает, чему равен его периметр и площадь.
2. Создать программу, которая, запросив целое двухзначное число, выдает, чему равна сумма и произведение цифр этого числа.
Паскаль.
Answers & Comments
Ответ:
Первая программа:
program p1;
var
a,p,s : integer;
begin
write('Введите сторону квадрата:');
readln(a);
p := a * 4;
s := a * a;
writeln('Периметр квадрата = ', p);
writeln('Площадь квадрата = ', s);
readln;
end.
Вторая программа:
program p2;
var
a,p,s,pow : integer;
begin
write('Введите число: ');
readln(a);
p := a mod 10;
s := (a div 10) mod 10;
pow := p * s;
writeln('Произведение цифр числа: ', pow);
readln;
end.