Помогите!!! Практическое задание №7
Тема: Знакомство с языком Паскаль.
1. а) Набрать в редакторе системы Турбо-Паскаль следующую программу:
Program my;
Var a,b,c,s:integer;
Begin
ReadLn(a);
ReadLn(b);
ReadLn(c);
S:=a*b*c;
WriteLn(S)
End.
б) Откомпилировать набранную программу и исправить ошибки.
в) Запустить данную программу на выполнение и проверить правильность её работы для чисел 2, 4 и 6.
г) Запустить данную программу на выполнение и проверить правильность её работы для чисел 1, 0 и -1.
д) Запустить данную программу на выполнение и проверить правильность её работы для чисел -2, 3 и 10.
2. Написать программу, которая присваивает целой переменной A значение 10 и выводит это значение на экран.
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, -5, 256, 10455.
4. Написать программу, которая запрашивает ввод вещественного числа в перемен-ную C, умножает это число на 2 и выводит результат на экран. Проверить правильность работы программы на числах 2.5, -7.33, 0, 782.234.
5. Написать программу для ввода значения величины X целого типа, присваивания величине Y действительного типа значения 5.5, вычисления значения величины Z = X - Y и вывода значения величины Z. Протестировать программу для X=5.5, X=0, X=-10.2
Answers & Comments