Помогите решить задачу: в массиве хранится информация о среднедневной температуре декабря. Составьте программу, которая подсчитывает, сколько в декабре было дней с нулевой, отрицательной и положительной температурой. Даю 22 балла.
Answers & Comments
Ленгит// PascalABC.NET 3.3, сборка 1576 от 16.11.2017 // Внимание! Если программа не работает, обновите версию!
begin var a:=ArrRandom(31,-10,12); a.Println; Writeln('Дней с нулевой температурой- ',a.Where(t->t=0).Count); Writeln('Дней с отрицательной температурой- ',a.Where(t->t<0).Count); Writeln('Дней с положительной температурой- ',a.Where(t->t>0).Count); end.
Пример 9 -8 0 -10 5 -10 5 -8 -5 8 -2 0 -7 -5 3 6 10 5 -5 1 5 5 10 -3 -3 6 8 7 6 7 12 Дней с нулевой температурой- 2 Дней с отрицательной температурой- 11 Дней с положительной температурой- 18
Если хочется вводить с клавиатуры, вместо строки var a:=ArrRandom(n,-10,12); a.Println; надо написать var a:=ReadArrInteger('Введите температуру по дням'+NewLine,31);
Answers & Comments
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(31,-10,12); a.Println;
Writeln('Дней с нулевой температурой- ',a.Where(t->t=0).Count);
Writeln('Дней с отрицательной температурой- ',a.Where(t->t<0).Count);
Writeln('Дней с положительной температурой- ',a.Where(t->t>0).Count);
end.
Пример
9 -8 0 -10 5 -10 5 -8 -5 8 -2 0 -7 -5 3 6 10 5 -5 1 5 5 10 -3 -3 6 8 7 6 7 12
Дней с нулевой температурой- 2
Дней с отрицательной температурой- 11
Дней с положительной температурой- 18
Если хочется вводить с клавиатуры, вместо строки
var a:=ArrRandom(n,-10,12); a.Println;
надо написать
var a:=ReadArrInteger('Введите температуру по дням'+NewLine,31);