August 2021 0 22 Report
Помогите решить задачу в паскаль!!! Последовательность состоит из натуральных чисел и завершается числом 0. Всего вводится не более 10000 чисел (не считая завершающего числа 0). Определите, сколько элементов этой последовательности равны ее наибольшему элементу.Числа, следующие за числом 0, считывать не нужно.
у меня есть такой вариант но нужен еще один 
readln(a);begin
if a > 0 then
if (max = 0) or (a > max) then
begin 
max := a;
k := 1 end
else if a = max then 
inc(k);
end;
until a=0;
write(k);
end.
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Copyright © 2025 SCHOLAR.TIPS - All rights reserved.