ПОМОГИТЕ ЗАДАЧУ В ПАСКАЛЕ РЕШИТЬ!
Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000 программа должна вывести два числа: сумму чисел и разность количества положительных и отрицательных чисел. Пример работы программы:
Входные данные:150;-200;-1;0
Выходные данные:-51;-1
Answers & Comments
program HelloWorld;var i, x, y, z: integer;begin
i:=1;while i<>0 do begin readln(i); x:=x+i; if i>0 then y:=y+1; if i<0 z:=z+1 end;writeln(x, ';', y-z); end.