Помогите,пожалуйста. Надобно написать программу в паскале. Заполнить массив случайными числами в интервале от -10 до 10 и выполнить инверсию отдельно для 1 и 2 части. Пример: 1 -2 6 -8 -3 | 5 -7 1 0 -4 -3 -8 6 -2 1 | -4 0 1 -7 5
Answers & Comments
juliazdanovska
Program xax; var i:shortint; a,b: array [-10..10] of byte; begin randomize; for i:=-10 to 10 do begin a[i]:=random(100); write(a[i],' '); end; writeln; for i:=-10 to -1 do b[i]:=a[-11-i]; for i:=1 to 10 do b[i]:=a[11-i]; b[0]:=a[0]; for i:=-10 to 10 do write(b[i],' '); end.
Answers & Comments
var i:shortint;
a,b: array [-10..10] of byte;
begin
randomize;
for i:=-10 to 10 do
begin
a[i]:=random(100);
write(a[i],' ');
end;
writeln;
for i:=-10 to -1 do
b[i]:=a[-11-i];
for i:=1 to 10 do
b[i]:=a[11-i];
b[0]:=a[0];
for i:=-10 to 10 do
write(b[i],' ');
end.